MapLayerSources Class
A collection of MapLayerSource objects.
Methods
Name | Description | |
---|---|---|
findByName(name: string, baseMap: booleanfalse): undefined | MapLayerSource | ||
addSourceToMapLayerSources(mapLayerSource?: MapLayerSource): Promise<undefined | MapLayerSources> Static | ||
create(iModel?: IModelConnection, queryForPublicSources: booleanfalse, addMapBoxSources: booleanfalse): Promise<MapLayerSources> Static | ||
getInstance(): undefined | MapLayerSources Static | ||
removeLayerByName(name: string): boolean Static |
Properties
Name | Type | Description | |
---|---|---|---|
allSource Accessor ReadOnly | MapLayerSource[] | ||
bases Accessor ReadOnly | MapLayerSource[] | ||
layers Accessor ReadOnly | MapLayerSource[] |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.