MapFeatureInfoRecord Class
Contains record data of a MapLayerFeature instance .
Extends
Methods
Name | Description | |
---|---|---|
constructor(value: PropertyValue, property: PropertyDescription): MapFeatureInfoRecord | Construct a record from PropertyValue and PropertyDescription objects. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
copyWithNewValue(newValue: PropertyValue, newDescription?: PropertyDescription): PropertyRecord Inherited | PropertyRecord | Creates a copy of this PropertyRecord with a new value and optionally a new PropertyDescription |
getChildrenRecords(): PropertyRecord[] Inherited | PropertyRecord | Gets this property record value children records |
fromString(value: string, descriptionOrName?: string | PropertyDescription): PropertyRecord Static Inherited | PropertyRecord | Creates a PropertyRecord based on a value string and an optional property description or name |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
autoExpand Inherited | boolean | undefined | PropertyRecord | Indicates if the property should be automatically expanded |
description Inherited | string | undefined | PropertyRecord | Description for the property |
extendedData Inherited | { T } | undefined | PropertyRecord | Map containing any additional data |
isDisabled Inherited | boolean | undefined | PropertyRecord | Indicates if the property is disabled |
isMerged Inherited | boolean | undefined | PropertyRecord | Indicates if the property record represents merged properties |
isReadonly Inherited | boolean | undefined | PropertyRecord | Indicates if the property is read-only |
links Inherited | LinkElementsInfo | undefined | PropertyRecord | Properties for link logic |
property Readonly Inherited | PropertyDescription | PropertyRecord | The property description containing metadata for the property |
value Readonly Inherited | PropertyValue | PropertyRecord | Value for the property |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.