ElectronHost Class
The backend for Electron-based desktop applications
Methods
Name | Description | |
---|---|---|
getWindowMaximizedSetting(windowName: string): undefined | boolean Static | Gets "window maximized" flag for a window, by name, from settings file if present | |
getWindowSizeAndPositionSetting(windowName: string): undefined | WindowSizeAndPositionProps Static | Gets window size and position for a window, by name, from settings file, if present. | |
openMainWindow(windowOptions?: ElectronHostWindowOptions): Promise<void> Static | Open the main Window when the app is ready. | |
startup(opts?: ElectronHostOpts): Promise<void> Static | Initialize the backend of an Electron app. |
Properties
Name | Type | Description | |
---|---|---|---|
app Accessor Static ReadOnly | Electron.App | ||
appIconPath Static | string | ||
electron Accessor Static ReadOnly | |||
frontendURL Static | string | ||
ipcMain Accessor Static ReadOnly | Electron.IpcMain | ||
isValid Accessor Static ReadOnly | boolean | ||
mainWindow Accessor Static ReadOnly | undefined | Electron.CrossProcessExports.BrowserWindow | The "main" BrowserWindow for this application. | |
rpcConfig Static | RpcConfiguration | ||
webResourcesPath Static | string |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.