ElectronHostWindowOptions Interface
Extends
- Electron.CrossProcessExports.BrowserWindowConstructorOptions
Properties
Name | Type | Description | |
---|---|---|---|
storeWindowName | string | undefined | Name used to construct key for saving window size, position and maximize status to the settings store | |
titleBarStyle | "default" | "hidden" | "hiddenInset" | "customButtonsOnHover" | The style of window title bar. | |
webPreferences | Omit<Electron.WebPreferences, "preload" | "experimentalFeatures" | "nodeIntegration" | "contextIsolation" | "sandbox" | "nodeIntegrationInWorker" | "nodeIntegrationInSubFrames"> | undefined | Web page settings |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.