BentleyCloudRpcManager Class
Coordinates usage of RPC interfaces for Bentley cloud deployments.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): BentleyCloudRpcManager | ||
initializeClient(params: BentleyCloudRpcParams, interfaces: RpcInterfaceDefinition<RpcInterface>[], routing: RpcRoutingTokenRpcRoutingToken.default): BentleyCloudRpcConfiguration Static | Initializes BentleyCloudRpcManager for the frontend of an application. | |
initializeImpl(params: BentleyCloudRpcParams, interfaces: RpcInterfaceDefinition<RpcInterface>[]): BentleyCloudRpcConfiguration Static | Initializes BentleyCloudRpcManager for the backend of an application. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
describeAvailableEndpoints(): Promise<RpcInterfaceEndpoints[]> Static Inherited | RpcManager | Describes the RPC interfaces and endpoints that are currently available from the backend. |
getClientForInterface<T extends RpcInterface>(definition: RpcInterfaceDefinition<T>, routing: RpcRoutingTokenRpcRoutingToken.default): T Static Inherited | RpcManager | Returns the RPC client instance for the frontend. |
initializeInterface<T extends RpcInterface>(definition: RpcInterfaceDefinition<T>): void Static Inherited | RpcManager | Initializes an RPC interface class. |
registerImpl<TDefinition extends RpcInterface, TImplementation extends RpcInterface>(definition: RpcInterfaceDefinition<TDefinition>, implementation: RpcInterfaceImplementation<TImplementation>): void Static Inherited | RpcManager | Register the RPC implementation class for the backend. |
setIModel(props: IModelRpcProps): void Static Inherited | RpcManager | Configures RPC protocols that employ iModel-based routing infrastructure. |
supplyImplInstance<TDefinition extends RpcInterface, TImplementation extends RpcInterface>(definition: RpcInterfaceDefinition<TDefinition>, instance: TImplementation): void Static Inherited | RpcManager | Supply the instance of the RPC interface implementation class for the backend (optional). |
terminateInterface<T extends RpcInterface>(definition: RpcInterfaceDefinition<T>): void Static Inherited | RpcManager | Terminates an RPC interface class. |
unregisterImpl<TDefinition extends RpcInterface>(definition: RpcInterfaceDefinition<TDefinition>): void Static Inherited | RpcManager | Unregister the RPC implementation class for the backend. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.