BentleyCloudRpcConfiguration Class
Operating parameters for Bentley cloud RPC interface deployments.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): BentleyCloudRpcConfiguration |
Inherited methods
Name | Inherited from | Description |
---|---|---|
assignWithRouting<T extends RpcInterface>(definition: RpcInterfaceDefinition<T>, routing: RpcRoutingToken, configuration: () => RpcConfiguration): void Static Inherited | RpcConfiguration | Sets the configuration supplier for an RPC interface class for a given routing. |
initializeInterfaces(configuration: RpcConfiguration): void Static Inherited | RpcConfiguration | Initializes the RPC interfaces managed by the configuration. |
obtain<T extends RpcConfiguration>(configurationConstructor: () => T): T Static Inherited | RpcConfiguration | Obtains the instance of an RPC configuration class. |
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
developmentMode Static Inherited | boolean | RpcConfiguration | Whether development mode is enabled. |
disableRoutingValidation Static Inherited | boolean | RpcConfiguration | Whether frontend checks that are relevant in a cloud-hosted routing scenario are disabled. |
interfaces Abstract Readonly Inherited | () => RpcInterfaceDefinition<RpcInterface>[] | RpcConfiguration | The RPC interfaces managed by the configuration. |
pendingOperationRetryInterval Inherited | number | RpcConfiguration | The target interval (in milliseconds) between connection attempts for pending RPC operation requests. |
strictMode Static Inherited | boolean | RpcConfiguration | Whether strict mode is enabled. |
throwOnTokenMismatch Static Inherited | boolean | RpcConfiguration | Whether to throw an error when the IModelRpcProps in the operation parameter list differs from the token in the URL. |
transientFaultLimit Inherited | number | RpcConfiguration | The maximum number of transient faults permitted before request failure. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.