ConflictingLocksError Class

An error raised when there is a lock conflict detected. Typically this error would be thrown by LockControl.acquireLocks when you are requesting a lock on an element that is already held by another briefcase.

Extends

Methods

Name Description
constructor(message: string, getMetaData?: LoggingMetaData, conflictingLocks?: ConflictingLock[]): ConflictingLocksError    
isError<T extends ConflictingLocks>(error: any): error is T Static    

Inherited methods

Name Inherited from Description
_initName(): string Protected Inherited IModelError This function returns the name of each error status.
IModelError get the meta data associated with this BentleyError, if any.
getErrorKey(errorNumber: number): string Static Inherited IModelError This function returns the name of each error status.
getErrorMessage(error: unknown): string Static Inherited IModelError Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists.
IModelError Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorProps(error: unknown): ErrorProps Static Inherited IModelError Returns a new ErrorProps object representing an unknown error value.
getErrorStack(error: unknown): undefined | string Static Inherited IModelError Use run-time type checking to safely get the call stack of an unknown error value, if possible.
IModelError get the metadata object associated with an ExceptionMetaData, if any.

Properties

Name Type Description
conflictingLocks ConflictingLock[] | undefined    

Inherited properties

Name Type Inherited from Description
errorNumber Inherited number IModelError  
boolean IModelError Returns true if this BentleyError includes (optional) metadata.
iTwinErrorId Accessor Inherited ReadOnly { key: string, scope: string } IModelError supply the value for iTwinErrorId
iTwinErrorScope Static Readonly Inherited "bentley-error" IModelError  
undefined | object IModelError value for logging metadata

Defined in

Last Updated: 03 April, 2025