ConflictingLocks Interface
Interface that describes the contents of ConflictingLocksError
without relying on that class, since
the exception may be marshalled across process boundaries and the class will not survive.
@see isError
Extends
Properties
Name | Type | Description | |
---|---|---|---|
conflictingLocks | ConflictingLock[] | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
errorNumber Readonly Inherited | number | LegacyITwinErrorWithNumber | a number to identify the error. |
iTwinErrorId Readonly Inherited | ITwinErrorId | LegacyITwinErrorWithNumber | Uniquely identifies the kind of error. |
loggingMetadata Inherited | object | undefined | LegacyITwinErrorWithNumber | Logging metadata |
Defined in
- core/common/src/IModelError.ts Line 66
Last Updated: 04 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.