ElementGeometry.IteratorEntry Class
Implements
Methods
Name | Description | |
---|---|---|
constructor(geomParams: GeometryParams, localToWorld: Transform, applyLocalToWorld?: boolean): ElementGeometry.IteratorEntry | ||
toBRepData(wantBRepData: booleanfalse): undefined | BRepEntity.DataProps | Return the DataProps representation for the current entry for checking brep type and face attachments. | |
toGeometryPart(partToLocal?: Transform, partToWorld?: Transform): undefined | string | Return the GeometryPart information for the current entry | |
toGeometryQuery(): undefined | GeometryQuery | Return the GeometryQuery representation for the current entry | |
toImageGraphic(): undefined | ImageGraphic | Return the ImageGraphic representation for the current entry | |
toTextString(): undefined | TextString | Return the TextString representation for the current entry |
Properties
Name | Type | Description | |
---|---|---|---|
geomParams Readonly | GeometryParams | A GeometryParams representing the appearance of the current geometric entry | |
localRange | Range3d | undefined | Optional stored local range for the current geometric entry | |
localToWorld Readonly | Transform | undefined | Placement transform, used for converting placement relative, local coordinate entries to world | |
outputTransform Accessor ReadOnly | undefined | Transform | ||
value Accessor | ElementGeometryDataEntry | The current displayable opcode |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.