ElementGeometry.IteratorData Interface

Current state information for Iterator

Implemented by

Properties

Name Type Description
geomParams Readonly GeometryParams A GeometryParams representing the appearance of the current geometric entry  
localRange Readonly Range3d | undefined Optional stored local range for the current geometric entry  
localToWorld Readonly Transform | undefined Placement transform, used for converting placement relative, local coordinate entries to world  
value Readonly ElementGeometryDataEntry The current displayable opcode  

Defined in

Last Updated: 21 November, 2024