createWithCamera MethodStatic
Create a SpatialViewDefinition with the camera turned on.
createWithCamera(iModelDb: IModelDb, definitionModelId: string, name: string, modelSelectorId: string, categorySelectorId: string, displayStyleId: string, range: Range3d, standardView: StandardViewIndexStandardViewIndex.Iso, cameraAngle: numberAngle.piOver2Radians): SpatialViewDefinition
@returns The newly constructed SpatialViewDefinition element
@throws IModelError if there is a problem creating the view
Parameter | Type | Description |
---|---|---|
iModelDb | IModelDb | The iModel |
definitionModelId | string | The DefinitionModel |
name | string | The name/CodeValue of the view |
modelSelectorId | string | The ModelSelector that this view should use |
categorySelectorId | string | The CategorySelector that this view should use |
displayStyleId | string | The DisplayStyle3d that this view should use |
range | Range3d | Defines the view origin and extents |
standardView | StandardViewIndex | Optionally defines the view's rotation |
cameraAngle | number | Camera angle in radians. |
Returns - SpatialViewDefinition
The newly constructed SpatialViewDefinition element
Defined in
- core/backend/src/ViewDefinition.ts Line 379
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.