ImageSourceFromImageBufferArgs Interface

Arguments supplied to imageSourceFromImageBuffer.

Properties

Name Type Description
flipVertically boolean | undefined If true, invert the order of the rows of the encoded image.  
image ImageBuffer The image to be encoded.  
jpegQuality number | undefined If targetFormat is (or defaults to) ImageSourceFormat.Jpeg, an integer between 0 and 100 indicating  
targetFormat ImageSourceFormat.Jpeg | ImageSourceFormat.Png The desired encoding for the resultant BinaryImageSource.  

Defined in

Last Updated: 21 February, 2025