BinaryImageSource Interface
An ImageSource encoded in binary form as a Jpeg or Png, as opposed to one encoded in string format as an Svg. Only binary ImageSources can be used for Textures stored in IModelDbs.
Properties
Name | Type | Description | |
---|---|---|---|
data Readonly | Uint8Array | The image data encoded according to format. | |
format Readonly | Jpeg | Png | The format in which the data is encoded. |
Defined in
- core/common/src/Image.ts Line 151
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.