HubArgs Class
Arguments specific to iModelHub used in a connector job
Implements
- HubArgsProps
- Validatable
Methods
Name | Description | |
---|---|---|
constructor(props: HubArgsProps): HubArgs |
Properties
Name | Type | Description | |
---|---|---|---|
briefcaseFile | string | undefined | Briefcase File | |
briefcaseId | number | undefined | Briefcase Id (optional) | |
clientConfig | NodeCliAuthorizationConfiguration | undefined | Node Cli Authorization Configuration (optional) | |
doInteractiveSignIn | boolean | Whether or not to require input from user to authenticate | |
iModelGuid | string | iModel Guid | |
isValid Accessor ReadOnly | boolean | ||
maxLockRetries | number | Number of attempts to obtain a lock before failing | |
maxLockRetryWaitSeconds | number | Number of seconds to wait before retrying to obtain lock | |
projectGuid | string | Project Guid | |
region | ConnectRegion | Connect Region "0" | "102" | "103" | |
tokenCallback | () => Promise<string> | undefined | Token Callback (optional) | |
tokenCallbackUrl | string | undefined | Token Callback Url (optional) |
Defined in
- Args.ts Line 126
Last Updated: 12 September, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.