createCategorizedProperty Method
Converts record into FlatGridItem.
createCategorizedProperty(record: PropertyRecord, parentSelectionKey: string, parentCategorySelectionKey: string, depth: number, overrideName?: string, overrideDisplayLabel?: string): IMutableCategorizedPropertyItem
@returns converted CategorizedProperty.
Parameter | Type | Description |
---|---|---|
record | PropertyRecord | record to convert to a FlatGridItem. |
parentSelectionKey | string | parent selection key of provided record . |
parentCategorySelectionKey | string | parent category selection key of provided record . |
depth | number | current depth counting from parent category. |
overrideName | string | property name that overrides original record property name. |
overrideDisplayLabel | string | property display label that overrides original record property display label. |
Returns - IMutableCategorizedPropertyItem
converted CategorizedProperty.
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.