sortFields Method
Deprecated in 4.5. Use sortFieldsAsync instead. This method is not async, therefore it requires early initialization by calling initializeConnection.
Sorts an array of fields with respect to favorite property order. Non-favorited fields get sorted by their default priority and always have lower priority than favorited fields.
sortFields(imodel: IModelConnection, fields: Field[]): Field[]
@note initializeConnection
must be called with the imodel
before calling this function.
Parameter | Type | Description |
---|---|---|
imodel | IModelConnection | IModelConnection. |
fields | Field[] | Array of Field's that needs to be sorted. |
Returns - Field[]
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.