has Method

Deprecated  in 4.5. Use hasAsync instead. This method is not async, therefore it requires early initialization by calling initializeConnection.

Check if field contains at least one favorite property.

has(field: Field, imodel: IModelConnection, scope: FavoritePropertiesScope): boolean

@note initializeConnection must be called with the imodel before calling this function.

Parameter Type Description
field Field Field that contains properties.
imodel IModelConnection IModelConnection.
scope FavoritePropertiesScope FavoritePropertiesScope to check for favorite properties. It also checks the more general scopes.

Returns - boolean

Defined in

Last Updated: 21 November, 2024