viewWithUnifiedSelection Function
Deprecated in 5.7. Use enableUnifiedSelectionSyncWithIModel
from @itwin/unified-selection
package instead.
A HOC component that adds unified selection functionality to the supplied viewport component.
viewWithUnifiedSelection<P extends ViewportProps>(ViewportComponent: React.ComponentType<P>): React.ComponentType<P>
Parameter | Type | Description |
---|---|---|
ViewportComponent | React.ComponentType<P> |
Returns - React.ComponentType<P>
Defined in
Last Updated: 07 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.