UnifiedSelectionTreeEventHandler Class
Tree event handler that handles unified selection. Extends wrapped tree event handler's functionality by adding, removing or replacing nodes in unified selection. It also reacts to unified selection changes and selects/deselects tree nodes according changes.
Note: conditions used to determine if node is selected and nodes that should be added to unified selection can be controlled by overriding 'shouldSelectNode' and 'createKeysForSelection' methods.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(params: UnifiedSelectionTreeEventHandlerParams): UnifiedSelectionTreeEventHandler | ||
createKeysForSelection(nodes: TreeNodeItem[], _selectionType: SelectionChangeType): Keys Protected | Returns node keys that should be added, removed or used to replace unified selection. | |
dispose(): void | ||
getKeys(nodes: TreeNodeItem[]): Keys Protected | ||
getNodeKey(node: TreeNodeItem): NodeKey Protected | Deprecated | |
onSelectionModified(__namedParameters: TreeSelectionModificationEventArgs): undefined | Subscription | ||
onSelectionReplaced(__namedParameters: TreeSelectionReplacementEventArgs): undefined | Subscription | ||
selectNodes(modelChange?: TreeModelChanges): void | ||
shouldSelectNode(node: TreeNodeItem, selection: Readonly<KeySet>): boolean Protected | Determines if node should be selected. |
Defined in
Last Updated: 15 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.