UsePresentationTableWithUnifiedSelectionProps<TColumn, TRow> Interface
Props for usePresentationTableWithUnifiedSelection hook.
Extends
- Omit<UsePresentationTableProps<TColumn, TRow>, "keys">
Properties
Name | Type | Description | |
---|---|---|---|
selectionStorage | SelectionStorage | undefined | Unified selection storage to use for listening, getting and changing active selection. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
columnMapper Inherited | (columns: TableColumnDefinition) => TColumn | Omit | Function that maps one column from generic TableColumnDefinition to table component specific type. |
imodel Inherited | IModelConnection | Omit | iModel connection to pull data from. |
pageSize Inherited | number | Omit | Paging size for obtaining rows. |
rowMapper Inherited | (row: TableRowDefinition) => TRow | Omit | Function that maps one row from generic TableRowDefinition to table component specific type. |
ruleset Inherited | string | Ruleset | Omit | Ruleset or ruleset id that should be used to load data. |
Defined in
Last Updated: 10 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.