usePresentationTableWithUnifiedSelection Function

Custom hook that load data for generic table component. It uses Unified Selection to get keys defining what to load rows for.

usePresentationTableWithUnifiedSelection<TColumn, TRow>(props: UsePresentationTableWithUnifiedSelectionProps<TColumn, TRow>): UsePresentationTableWithUnifiedSelectionResult<TColumn, TRow>

@throws on failure to get table data. The error is thrown in the React's render loop, so it can be caught using an error boundary.

Parameter Type Description
props UsePresentationTableWithUnifiedSelectionProps<TColumn, TRow>  

Returns - UsePresentationTableWithUnifiedSelectionResult<TColumn, TRow>

Defined in

Last Updated: 10 February, 2025