FavoritePropertiesDataProvider Class
Presentation Rules-driven element favorite properties data provider implementation.
Implements
Methods
Name | Description | |
---|---|---|
constructor(props?: FavoritePropertiesDataProviderProps): FavoritePropertiesDataProvider | Constructor. | |
getData(imodel: IModelConnection, elementIds: KeySet | Id64Arg): Promise<PropertyData> | Returns PropertyData for the specified elements. |
Properties
Name | Type | Description | |
---|---|---|---|
includeFieldsWithCompositeValues | boolean | Should fields with composite values be included in the property list. | |
includeFieldsWithNoValues | boolean | Should fields with no values be included in the property list. |
Defined in
Last Updated: 15 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.