PresentationLabelsProvider Class
Presentation Rules-driven labels provider implementation.
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: PresentationLabelsProviderProps): PresentationLabelsProvider | Constructor. | |
getLabel(key: InstanceKey): Promise<string> | Returns label for the specified instance key. | |
getLabels(keys: InstanceKey[]): Promise<string[]> | Returns labels for the specified instance keys. |
Properties
Name | Type | Description | |
---|---|---|---|
imodel Readonly | IModelConnection | IModelConnection used by this data provider |
Defined in
Last Updated: 15 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.