MultiElementPropertiesByClassRequestOptions<TIModel, TParsedContent> Interface
Request type for multiple elements properties requests, where elements are specified by class.
Extends
- MultiElementPropertiesBaseRequestOptions<TIModel, TParsedContent>
Properties
Name | Type | Description | |
---|---|---|---|
elementClasses | string[] | undefined | Classes of the elements to get properties for. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
batchSize Inherited | number | undefined | MultiElementPropertiesBaseRequestOptions<TIModel, TParsedContent> | The properties of multiple elements are going to be retrieved and returned in batches. |
contentParser Inherited | (descriptor: Descriptor, item: Item) => TParsedContent | undefined | MultiElementPropertiesBaseRequestOptions<TIModel, TParsedContent> | Content parser that creates a result item based on given content descriptor and content item. |
imodel Inherited | TIModel | MultiElementPropertiesBaseRequestOptions<TIModel, TParsedContent> | iModel to request data from |
locale Inherited | string | undefined | MultiElementPropertiesBaseRequestOptions<TIModel, TParsedContent> | Optional locale to use when formatting / localizing data |
unitSystem Inherited | UnitSystemKey | undefined | MultiElementPropertiesBaseRequestOptions<TIModel, TParsedContent> | Unit system to use when formatting property values with units. |
Defined in
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.