MultiElementPropertiesBaseRequestOptions<TIModel, TParsedContent> Interface

Base request type for multiple elements properties requests.

Extends

Properties

Name Type Description
batchSize number | undefined The properties of multiple elements are going to be retrieved and returned in batches.  
contentParser (descriptor: Descriptor, item: Item) => TParsedContent | undefined Content parser that creates a result item based on given content descriptor and content item.  

Inherited properties

Name Type Inherited from Description
imodel Inherited TIModel RequestOptions<TIModel> iModel to request data from
locale Inherited string | undefined RequestOptions<TIModel> Optional locale to use when formatting / localizing data
unitSystem Inherited UnitSystemKey | undefined RequestOptions<TIModel> Unit system to use when formatting property values with units.

Defined in

Last Updated: 18 January, 2025