StructPropertiesField Class

Describes a content field that's based on one or more similar EC struct properties.

Extends

Methods

Name Description
constructor(props: StructPropertiesFieldProps): StructPropertiesField Creates an instance of StructPropertiesField.  
constructor(category: CategoryDescription, name: string, label: string, type: TypeDescription, memberFields: PropertiesField[], isReadonly: boolean, priority: number, properties: Property[], editor?: EditorDescription, renderer?: RendererDescription): StructPropertiesField Creates an instance of StructPropertiesField. Deprecated  
clone(): StructPropertiesField    
isStructPropertiesField(): this is StructPropertiesField Is this a an struct property field  
toCompressedJSON(classesMap: [id: string]: CompressedClassInfoJSON): StructPropertiesFieldJSON<string> Serialize this object to compressed JSON  
toJSON(): StructPropertiesFieldJSON<ClassInfo> Serialize this object to JSON. Deprecated  
fromCompressedJSON(json: StructPropertiesFieldJSON<string>, classesMap: [id: string]: CompressedClassInfoJSON, categories: CategoryDescription[]): StructPropertiesField Static Deserialize a StructPropertiesField from compressed JSON.  
fromJSON(json: StructPropertiesFieldJSON<ClassInfo>, categories: CategoryDescription[]): StructPropertiesField Static Deserialize StructPropertiesField from JSON. Deprecated  

Inherited methods

Name Inherited from Description
getFieldDescriptor(): FieldDescriptor Inherited PropertiesField Get descriptor for this field.
isArrayPropertiesField(): this is ArrayPropertiesField Inherited PropertiesField Is this a an array property field
isNestedContentField(): this is NestedContentField Inherited PropertiesField Is this a NestedContentField
isPropertiesField(): this is PropertiesField Inherited PropertiesField Is this a PropertiesField
matchesDescriptor(descriptor: FieldDescriptor): boolean Inherited PropertiesField Checks if this field matches given field descriptor
rebuildParentship(parentField?: NestedContentField): void Inherited PropertiesField Sets provided NestedContentField as parent of this field.
resetParentship(): void Inherited PropertiesField Resets field's parent.
getCategoryFromFieldJson(fieldJson: FieldJSON<ClassInfo>, categories: CategoryDescription[]): CategoryDescription Protected Static Inherited PropertiesField  

Properties

Name Type Description
memberFields PropertiesField[]    

Inherited properties

Name Type Inherited from Description
category Inherited CategoryDescription PropertiesField Category information
editor Inherited EditorDescription | undefined PropertiesField Property editor used to edit values of this field
extendedData Inherited [key: string]: unknown | undefined PropertiesField Extended data associated with this field
isReadonly Inherited boolean PropertiesField Are values in this field read-only
label Inherited string PropertiesField Display label
name Inherited string PropertiesField Unique name
parent Accessor Inherited ReadOnly undefined | NestedContentField PropertiesField Get parent
priority Inherited number PropertiesField Priority of the field.
properties Inherited Property[] PropertiesField A list of properties this field is created from
renderer Inherited RendererDescription | undefined PropertiesField Property renderer used to render values of this field
type Inherited TypeDescription PropertiesField Description of this field's values data type

Defined in

Last Updated: 21 February, 2025