constructor Method


Item(props)

Item(props: ItemProps): Item

Parameter Type Description
props ItemProps  

Returns - Item



Item(primaryKeys, label, imageId, classInfo, values, displayValues, mergedFieldNames, extendedData?)

Deprecated  in 5.0. Use an overload with ItemProps instead.

Creates an instance of Item.

Item(primaryKeys: InstanceKey[], label: string | LabelDefinition, imageId: string, classInfo: ClassInfo, values: ValuesDictionary<Value>, displayValues: ValuesDictionary<DisplayValue>, mergedFieldNames: string[], extendedData?: [key: string]: any): Item

Parameter Type Description
primaryKeys InstanceKey[] Keys of instances whose data is contained in this item
label string | LabelDefinition Display label of the item
imageId string ID of the image associated with this item
classInfo ClassInfo For cases when item consists only of same class instances, information about the ECClass
values ValuesDictionary<Value> Raw values dictionary
displayValues ValuesDictionary<DisplayValue> Display values dictionary
mergedFieldNames string[] List of field names whose values are merged (see Merging values)
extendedData [key: string]: any Extended data injected into this content item

Returns - Item


Defined in

Last Updated: 21 February, 2025