RulesetInsertOptions Interface
Options for insertRuleset operation.
Properties
Name | Type | Description | |
---|---|---|---|
onEntityInsert | InsertCallbacks | undefined | Callbacks that will be called before and after Entity is inserted |
|
onEntityUpdate | UpdateCallbacks | undefined | Callbacks that will be called before and after Entity updates |
|
replaceVersions | "exact" | "all" | "all-lower" | Which existing versions of rulesets with same id should be replaced when we insert a new one: | |
skip | "never" | "same-id" | "same-id-and-version-eq" | "same-id-and-version-gte" | When should insertion be skipped: |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.