insertRuleset Method
Inserts a ruleset into iModel.
insertRuleset(ruleset: Ruleset, options?: RulesetInsertOptions): Promise<string>
@returns ID of inserted ruleset element or, if insertion was skipped, ID of existing ruleset with the same ID and highest version.
Parameter | Type | Description |
---|---|---|
ruleset | Ruleset | Ruleset to insert. |
options | RulesetInsertOptions | Options for inserting a ruleset. |
Returns - Promise
ID of inserted ruleset element or, if insertion was skipped, ID of existing ruleset with the same ID and highest version.
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.