TimelineComponentProps Interface
TimelineComponentProps configure the timeline
Properties
Name | Type | Description | |
---|---|---|---|
alwaysMinimized | boolean | undefined | Always display in miniMode with no expand menu (For future use. | Deprecated |
appMenuItemOption | TimelineMenuItemOption | undefined | How to include the supplied app menu items in the Timeline Context Menu (prefix, append or replace). | |
appMenuItems | TimelineMenuItemProps[] | undefined | App-supplied speed entries in the Timeline Context Menu. | |
componentId | string | undefined | ComponentId -- must be set to use TimelineComponentEvents | Deprecated |
dateFormatOptions | DateFormatOptions | undefined | Options used to format date string. | |
endDate | Date | undefined | End date: end of the date range of a date-based timeline. | |
includeRepeat | boolean | undefined | Include the repeat option on the Timeline Context Menu. | |
initialDuration | number | undefined | Initial value for the current duration (the location of the thumb) in milliseconds | |
isPlaying | boolean | undefined | Used to control the play/pause state of the Timeline. | |
markDate | TimelineDateMarkerProps | undefined | Display a marker on the timeline rail to indicate current date - will only work if starDate and endDate are defined | |
minimized | boolean | undefined | Show in minimized mode (For future use. | Deprecated |
onChange | (duration: number) => void | undefined | Callback with current duration value (as a fraction) | |
onJump | (forward: boolean) => void | undefined | Callback triggered when backward/forward buttons are pressed. | Deprecated |
onPlayPause | (playing: boolean) => void | undefined | Callback triggered when play/pause button is pressed | |
onSettingsChange | (arg: PlaybackSettings) => void | undefined | Callback triggered when a setting is changed | |
repeat | boolean | undefined | When playing, repeat indefinitely. | |
showDuration | boolean | undefined | Show duration instead of time | |
startDate | Date | undefined | Start date: beginning of the date range of a date-based timeline. | |
timeFormatOptions | DateFormatOptions | undefined | Options used to format time string. | |
timeZoneOffset | number | undefined | Display date and time offset by the number of minutes specified. | |
totalDuration | number | Total duration: range of the timeline in milliseconds. | |
trackContainerProps | React.HTMLAttributes<HTMLDivElement> | undefined | Props for a container that holds the slider thumbs and tracks. |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.