SnowParams Interface
Parameters controlling how a SnowDecorator works.
Properties
Name | Type | Description | |
---|---|---|---|
accelerationRange | Range2d | Range from which to randomly select an acceleration to apply to each particle's velocity each frame, in pixels per second squared, to simulate wind. | |
numParticles | number | The number of snow particles to produce. | |
sizeRange | Range1d | Range from which to randomly select each particle's size, in pixels. | |
transparencyRange | Range1d | Range from which to randomly select each particle's transparency. | |
velocityRange | Range2d | Range from which to randomly select each particle's initial velocity, in pixels per second. | |
windVelocity | number | Wind velocity in pixels per second in X. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.