SnowDecorator Class

Simulates snowfall in a Viewport using particle effects.

@see - SnowEffect for a Tool that toggles this decorator.

Implements

Methods

Name Description
configure(params: Partial<SnowParams>): void Change some of the parameters affecting this decorator.  
decorate(context: DecorateContext): void Implement this method to add Decorations into the supplied DecorateContext.  
toggle(viewport: Viewport, enable?: boolean): Promise<void> Static Toggle this decorator for the specified viewport.  

Properties

Name Type Description
[dispose] Readonly VoidFunction Invoked when this decorator is to be destroyed.  
viewport Readonly Viewport The viewport being decorated.  

Defined in

Last Updated: 20 February, 2025