EditCommandAdmin Class
EditCommandAdmin holds a mapping between commandIds and their corresponding EditCommand class. This provides the mechanism to run EditCommands by commandId. It also keeps track of the currently active EditCommand. When a new EditCommand attempts to start, the active EditCommand is requested to finish, and the new EditCommand cannot start until it does.
Methods
Name | Description | |
---|---|---|
constructor(): EditCommandAdmin | ||
finishCommand(): Promise<void> Static | If any command is currently active, wait for it to finish. | |
register(commandType: ): void Static | Register an EditCommand class. | |
registerModule(moduleObj: any): void Static | Register all the EditCommand classes found in a module. | |
runCommand(cmd: EditCommand): Promise<any> Static | Start running the specified command. | |
unRegister(commandId: string): void Static | Un-register a previously registered EditCommand class. |
Properties
Name | Type | Description | |
---|---|---|---|
activeCommand Accessor Static ReadOnly | undefined | EditCommand | ||
commands Static Readonly | Map<string, > |
Defined in
- EditCommand.ts Line 110
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.