BasicManipulationCommand Class

Implementation for a EditCommand command that provides basic creation and modification operations.

Extends

Implements

Methods

Name Description
constructor(iModel: IModelDb, _str: string): BasicManipulationCommand    
addAllowedChannel(channelKey: string): Promise<void>    
deleteElements(ids: string): Promise<IModelStatus>    
insertGeometricElement(props: GeometricElementProps): Promise<string> Create and insert a new geometric element.  
insertGeometryPart(props: GeometryPartProps): Promise<string> Create and insert a new geometry part element.  
onStart(): Promise<string>    
removeAllowedChannel(channelKey: string): Promise<void>    
requestElementGeometry(elementId: string, filter?: FlatBufferGeometryFilter): Promise<undefined | ElementGeometryInfo> Request geometry from an existing element.  
rotatePlacement(ids: string, matrixProps: Matrix3dProps, aboutCenter: boolean): Promise<IModelStatus>    
transformPlacement(ids: string, transProps: TransformProps): Promise<IModelStatus>    
updateEcefLocation(ecefLocation: EcefLocationProps): Promise<void> Update the position of the iModel on the earth.  
updateGeometricElement(propsOrId: string | GeometricElementProps, data?: ElementGeometryBuilderParams): Promise<void> Update an existing geometric element.  
updateProjectExtents(extents: Range3dProps): Promise<void> Update the project extents for the iModel.  

Inherited methods

Name Inherited from Description
ping(): Promise<{ commandId: string, version: string }> Inherited EditCommand Identify the current EditCommand's name and version, optionally returning additional properties that describe its state.
requestFinish(): Promise<string> Inherited EditCommand Called when another EditCommand wishes to become the active EditCommand.

Properties

Name Type Description
_str Protected string    
commandId Static string The unique string that identifies this EditCommand class.  

Inherited properties

Name Type Inherited from Description
ctor Accessor Inherited ReadOnly EditCommand  
iModel Readonly Inherited IModelDb EditCommand The iModel this EditCommand may modify.
version Static Inherited string EditCommand  

Defined in

Last Updated: 21 November, 2024