assertIsUnitSystem MethodStatic

Type assertion to check if the SchemaItem is of type UnitSystem.

assertIsUnitSystem(item?: SchemaItem): item is UnitSystem

@returns The item cast to UnitSystem if it is a UnitSystem, undefined otherwise.

Parameter Type Description
item SchemaItem The SchemaItem to check.

Returns - item is UnitSystem

The item cast to UnitSystem if it is a UnitSystem, undefined otherwise.

Defined in

Last Updated: 21 February, 2025