assertIsStructClass MethodStatic

Type assertion to check if the SchemaItem is of type StructClass.

assertIsStructClass(item?: SchemaItem): item is StructClass

@returns The item cast to StructClass if it is a StructClass, undefined otherwise.

Parameter Type Description
item SchemaItem The SchemaItem to check.

Returns - item is StructClass

The item cast to StructClass if it is a StructClass, undefined otherwise.

Defined in

Last Updated: 21 February, 2025