constructor Method
SchemaFormatsProvider(contextOrLocater: ISchemaLocater, unitSystem: UnitSystemKey): SchemaFormatsProvider
Parameter | Type | Description |
---|---|---|
contextOrLocater | ISchemaLocater | The SchemaContext or a different ISchemaLocater implementation used to retrieve the schema. The SchemaContext class implements the ISchemaLocater interface. If the provided locater is not a SchemaContext instance a new SchemaContext will be created and the locater will be added. |
unitSystem | UnitSystemKey | Used to lookup a default format through a schema specific algorithm, when the format retrieved is associated with a KindOfQuantity. |
Returns - SchemaFormatsProvider
Defined in
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.