SchemaFormatsProvider Class
Provides default formats and kind of quantities from a given SchemaContext or SchemaLocater.
Implements
Methods
Name | Description | |
---|---|---|
constructor(contextOrLocater: ISchemaLocater, unitSystem: UnitSystemKey): SchemaFormatsProvider | ||
getFormat(name: string): Promise<undefined | SchemaItemFormatProps> | Retrieves a Format from a SchemaContext. |
Properties
Name | Type | Description | |
---|---|---|---|
context Accessor ReadOnly | SchemaContext | ||
onFormatsChanged | BeEvent<(args: FormatsChangedArgs) => void> | ||
unitSystem Accessor | UnitSystemKey |
Defined in
Last Updated: 26 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.