PrimitiveProperty Class

Extends

Methods

Name Description
fromJSON(primitivePropertyProps: PrimitivePropertyProps): Promise<void>    
fromJSONSync(primitivePropertyProps: PrimitivePropertyProps): void    
toJSON(): PrimitivePropertyProps Save this PrimitiveProperty's properties to an object for serializing to JSON.  

Inherited methods

Name Inherited from Description
getCategorySync(): undefined | PropertyCategory Inherited PrimitiveOrEnumPropertyBase  
getCustomAttributes(): Promise<> Inherited PrimitiveOrEnumPropertyBase Retrieve all custom attributes in the current property and its base
getCustomAttributesSync(): Inherited PrimitiveOrEnumPropertyBase Retrieve all custom attributes in the current property and its base.
getKindOfQuantitySync(): undefined | KindOfQuantity Inherited PrimitiveOrEnumPropertyBase  
isArray(): this is AnyArrayProperty Inherited PrimitiveOrEnumPropertyBase  
isEnumeration(): this is AnyEnumerationProperty Inherited PrimitiveOrEnumPropertyBase  
isNavigation(): this is NavigationProperty Inherited PrimitiveOrEnumPropertyBase  
isPrimitive(): this is AnyPrimitiveProperty Inherited PrimitiveOrEnumPropertyBase  
isStruct(): this is AnyStructProperty Inherited PrimitiveOrEnumPropertyBase  

Properties

Name Type Description
primitiveType Accessor ReadOnly PrimitiveType    

Inherited properties

Name Type Inherited from Description
category Accessor Inherited ReadOnly undefined | LazyLoadedPropertyCategory PrimitiveOrEnumPropertyBase  
class Accessor Inherited ReadOnly AnyClass PrimitiveOrEnumPropertyBase  
customAttributes Accessor Inherited ReadOnly undefined | PrimitiveOrEnumPropertyBase  
description Accessor Inherited ReadOnly undefined | string PrimitiveOrEnumPropertyBase  
extendedTypeName Accessor Inherited ReadOnly undefined | string PrimitiveOrEnumPropertyBase  
fullName Accessor Inherited ReadOnly string PrimitiveOrEnumPropertyBase Returns the name in the format 'ClassName.PropertyName'.
isReadOnly Accessor Inherited ReadOnly boolean PrimitiveOrEnumPropertyBase  
kindOfQuantity Accessor Inherited ReadOnly undefined | LazyLoadedKindOfQuantity PrimitiveOrEnumPropertyBase  
label Accessor Inherited ReadOnly undefined | string PrimitiveOrEnumPropertyBase  
maxLength Accessor Inherited ReadOnly undefined | number PrimitiveOrEnumPropertyBase  
maxValue Accessor Inherited ReadOnly undefined | number PrimitiveOrEnumPropertyBase  
minLength Accessor Inherited ReadOnly undefined | number PrimitiveOrEnumPropertyBase  
minValue Accessor Inherited ReadOnly undefined | number PrimitiveOrEnumPropertyBase  
name Accessor Inherited ReadOnly string PrimitiveOrEnumPropertyBase  
priority Accessor Inherited ReadOnly number PrimitiveOrEnumPropertyBase  
propertyType Accessor Inherited ReadOnly PropertyType PrimitiveOrEnumPropertyBase  
schema Accessor Inherited ReadOnly Schema PrimitiveOrEnumPropertyBase Returns the schema of the class holding the property.

Defined in

Last Updated: 26 April, 2025