assertIsPhenomenon MethodStatic
Type assertion to check if the SchemaItem is of type Phenomenon.
assertIsPhenomenon(item?: SchemaItem): item is Phenomenon
@returns The item cast to Phenomenon if it is a Phenomenon, undefined otherwise.
Parameter | Type | Description |
---|---|---|
item | SchemaItem | The SchemaItem to check. |
Returns - item is Phenomenon
The item cast to Phenomenon if it is a Phenomenon, undefined otherwise.
Defined in
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.