isEntityClass MethodStatic

Type guard to check if the SchemaItem is of type EntityClass.

isEntityClass(item?: SchemaItem): item is EntityClass

@returns True if the item is an EntityClass, false otherwise.

Parameter Type Description
item SchemaItem The SchemaItem to check.

Returns - item is EntityClass

True if the item is an EntityClass, false otherwise.

Defined in

Last Updated: 21 February, 2025