assertIsEntityClass MethodStatic
Type assertion to check if the SchemaItem is of type EntityClass.
assertIsEntityClass(item?: SchemaItem): item is EntityClass
@returns The item cast to EntityClass if it is an EntityClass, undefined otherwise.
Parameter | Type | Description |
---|---|---|
item | SchemaItem | The SchemaItem to check. |
Returns - item is EntityClass
The item cast to EntityClass if it is an EntityClass, undefined otherwise.
Defined in
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.