getPropertiesSync Method

Returns the properties on this class and its base classes. Since this is an expensive operation, results will be cached after first call.

getPropertiesSync(excludeInherited?: boolean): Iterable<Property, any, any>

@returns An array of properties, empty array if none exist.

Parameter Type Description
excludeInherited boolean If true, only properties defined directly on this class will be returned. Defaults to false.

Returns - Iterable<Property, any, any>

An array of properties, empty array if none exist.

Defined in

Last Updated: 04 April, 2025