getProperties Method
Returns the properties on this class and its base classes. Since this is an expensive operation, results will be cached after first call.
getProperties(excludeInherited?: boolean): Promise<Iterable<Property, any, any>>
@returns An array of properties, empty array if none exist.
Parameter | Type | Description |
---|---|---|
excludeInherited | boolean | If true, only properties defined directly on this class will be returned. |
Returns - Promise<Iterable<Property, any, any>>
An array of properties, empty array if none exist.
Defined in
Last Updated: 04 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.