assertIsCustomAttributeClass MethodStatic

Type assertion to check if the SchemaItem is of type CustomAttributeClass.

assertIsCustomAttributeClass(item?: SchemaItem): item is CustomAttributeClass

@returns The item cast to CustomAttributeClass if it is a CustomAttributeClass, undefined otherwise.

Parameter Type Description
item SchemaItem The SchemaItem to check.

Returns - item is CustomAttributeClass

The item cast to CustomAttributeClass if it is a CustomAttributeClass, undefined otherwise.

Defined in

Last Updated: 21 February, 2025