getSchemaItemSync Method
getSchemaItemSync<T extends >(schemaItemKey, itemConstructor)
getSchemaItemSync<T extends >(schemaItemKey: SchemaItemKey, itemConstructor: T): undefined | InstanceType<T>
Parameter | Type | Description |
---|---|---|
schemaItemKey | SchemaItemKey | |
itemConstructor | T |
Returns - undefined | InstanceType<T>
getSchemaItemSync(schemaItemKey)
Gets the schema item from the specified schema if it exists in this SchemaContext. Will skip a partially loaded schema and return undefined if the item belongs to that schema. Use the async method to await partially loaded schemas.
getSchemaItemSync(schemaItemKey: SchemaItemKey): undefined | SchemaItem
@returns The requested schema item.
Parameter | Type | Description |
---|---|---|
schemaItemKey | SchemaItemKey | The SchemaItemKey identifying the item to return. SchemaMatchType.Latest is used to match the schema. |
Returns - undefined | SchemaItem
The requested schema item.
Defined in
- ecschema-metadata/src/Context.ts Line 84
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.