ISchemaItemLocater Interface
Base interface for types that allow location of items inside a schema
Implemented by
Methods
Name | Description | |
---|---|---|
getSchemaItem<T extends >(schemaItemKey: SchemaItemKey, itemConstructor: T): Promise<undefined | InstanceType<T>> | ||
getSchemaItem(schemaItemKey: SchemaItemKey): Promise<undefined | SchemaItem> | Gets the schema item from the specified schema if it exists in this SchemaContext. | |
getSchemaItemSync<T extends >(schemaItemKey: SchemaItemKey, itemConstructor: T): undefined | InstanceType<T> | ||
getSchemaItemSync(schemaItemKey: SchemaItemKey): undefined | SchemaItem | Gets the schema item from the specified schema if it exists in this SchemaContext. |
Defined in
- ecschema-metadata/src/Context.ts Line 67
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.