PropertyDiagnostic<ARGS extends any[]> Class
An IDiagnostic implementation used for Property diagnostics.
Extends
- BaseDiagnostic<AnyProperty, ARGS>
Methods
Name | Description | |
---|---|---|
constructor<ARGS extends any[]>(property: AnyProperty, messageArgs?: ARGS, category: DiagnosticCategoryDiagnosticCategory.Error): PropertyDiagnostic<ARGS> | Initializes a new PropertyDiagnostic. |
Properties
Name | Type | Description | |
---|---|---|---|
diagnosticType Accessor ReadOnly | DiagnosticType | Gets the DiagnosticType. | |
schema Accessor ReadOnly | Schema | Gets the schema where the diagnostic originated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category Inherited | DiagnosticCategory | BaseDiagnostic<AnyProperty, ARGS> | The diagnostic category is of the type DiagnosticCategory; which is defined as an enumeration above. |
code Accessor Abstract Inherited ReadOnly | string | BaseDiagnostic<AnyProperty, ARGS> | Gets the unique string identifier for the diagnostic in the format ' |
ecDefinition Inherited | AnyProperty | BaseDiagnostic<AnyProperty, ARGS> | The EC object to associate with the diagnostic. |
ARGS | undefined | BaseDiagnostic<AnyProperty, ARGS> | The arguments used when formatting the diagnostic message. | |
string | BaseDiagnostic<AnyProperty, ARGS> | Gets the message associated with the diagnostic. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.