ScrollPositionMaintainer Class
Deprecated in 4.15.0. Not use by AppUI.
A helper class to recursively save and restore scroll positions. Usage:
// scroll positions are saved when `ScrollPositionMaintainer` object is created
const maintainer = new ScrollPositionMaintainer(element);
// can do something with `element` here
// disposing the `maintainer` object restores scroll positions
maintainer.dispose();
Implements
Methods
Name | Description | |
---|---|---|
constructor(el: Element): ScrollPositionMaintainer | ||
dispose(): void |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.