IconHelper Class
Deprecated in 4.15.0. Used internally.
Icon Helper Class used to store the data needed to generate an
Methods
Name | Description | |
---|---|---|
constructor(): IconHelper | ||
getIconData(iconSpec: IconSpec, internalData?: Map<string, any>): string | ConditionalStringValue Static | Returns an icon definition that can be stored in an abstract item definition. | |
getIconReactNode(icon: React.ReactNode | ConditionalIconItem | ConditionalStringValue, internalData?: Map<string, any>): React.ReactNode Static | Returns an |
Properties
Name | Type | Description | |
---|---|---|---|
conditionalIconItemKey Accessor Static ReadOnly | string | ||
reactIconKey Accessor Static ReadOnly | string |
Defined in
Last Updated: 20 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.